Resolved
Document Editor is loading slowly

Started
July 25, 2023 at 3:53 PM
Status
Resolved after about 3 hours

Impact

Partial outage
Affected
Jasper Application
Jasper App
  • Resolved

    This incident has been resolved.

  • Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating

    We are currently investigating this incident.